SIGN UP

immersion thermostat failure

Avatar Image
ramp | 18:00 Mon 22nd Nov 2004 | Home & Garden
1 Answers
Have reconnected the power source to my immersion heater having had the tank replaced cos it leaked - now the gas boiler has packed up (solenoids on order) - and despite double checking and brother double checking, bearing in mind that it is a new tank with a new Backer immersion element and thermostat in new tank - it does not heat up the water - there is power at the fused switch as the neon light lights up - am I to assume that the new element/thermostat is faulty or could it be the cable to the thermostat? - any suggestions before I go out and buy a new thermostat for this would be appreciated

Answers

Only 1 answerrss feed

Best Answer

No best answer has yet been selected by ramp. Once a best answer has been selected, it will be shown here.

For more on marking an answer as the "Best Answer", please visit our FAQ.
The cable to the thermostat, from the fused switch, should connect to one side of the thermostat for the positive wire, and the other side of the thermostat connects to the heating element. The neutral wire connects to the other terminal of the heating element. And earth to earth.

Only 1 answerrss feed

Do you know the answer?

immersion thermostat failure

Answer Question >>

Related Questions

Sorry, we can't find any related questions. Try using the search bar at the top of the page to search for some keywords, or choose a topic and submit your own question.